Service disruption in Wheel Fitment API
Incident Report for Wheel Size Services
Postmortem

On March 25th of 2023 a very high rate of 500 HTTP responses was detected in the Service Management API frontend affecting 100% of the traffic. The root cause was tracked down to an intermediate proxy layer between the frontend instances and the sharded storage layer. Remediation actions were undertaken in this proxy layer to restore the service.

Timeline:

  • March 25th 2023, 19:22 UTC - high rate of HTTP 5XX errors starts (100% of traffic).
  • March 25th 2023, 20:00 UTC - solution implemented, incident resolved.

Root cause:

Unexpected error on an intermediate proxy layer between Service Management API frontend instances and sharded storage layer.

Posted Mar 26, 2023 - 12:13 GMT+06:00

Resolved
This incident has been resolved.

A postmortem will be published soon.
Posted Mar 26, 2023 - 02:15 GMT+06:00
Investigating
We are currently experiencing a service disruption in our Service Management API
Our operations team is working to identify the root cause and implement a solution.
Posted Mar 26, 2023 - 01:54 GMT+06:00
This incident affected: API (API).